Symptom
When a customer enables flat view for a specific business role, there is a claim that a specific View is suddenly not displayed any longer.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Login with affected user.
- Check that a specific View is missing.
- Login as Admin and change "Enable Flat List Navigation Menu" to "No" in Company Settings Menu.
- Login once again with affected user and check that view is once again being presented.
Cause
This happens due to settings created from "Organize Work Centers and Work Center Views".
Resolution
- Open "Administrator" and go to "General Settings".
- Click on "Organize Work Centers and Work Center Views".
- Select the required "Name" and "Navigation Type" as "Flat".
- Notice that checkboxes for visibility are unchecked.
- Change it, save and check the results.
Keywords
Enable; flat; view; business; role; user; Work Center; View; disappear; missing; deleted; Company; Settings; menu. , KBA , AP-RC-UIF , C4C UI Framework , How To
Product
SAP Cloud for Customer core applications 2402