Symptom
You are trying to scope iRPA or BPA in the tenant, however at the Review step of the scoping process, the following popup error appears:
"Currently unable to finalize these scope changes; some of your decisions would cause inconsistencies in your fine-tuning settings or the productive data.
If error messages are displayed. resolve them before you proceed."
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Business Configuration work center.
- Enter the Implementation Projects view.
- Select the implementation project.
- Click on the Edit Project Scope button.
- Navigate to step 3 - Scoping.
- Expand Communication and Information Exchange, then Integration with External Applications and Solutions.
- Check the checkbox for Integration Scenarios for Cloud Solutions from SAP.
- Now navigate to step 4 - Questions.
- Expand the same path from step 6.
- Click on the Integration Scenarios for Cloud Solutions from SAP row.
Here either select question "Do you want to enable integration with SAP Intelligent Robotic Process Automation?" or "Do you want to enable integration with SAP Build Process Automation (BPA)?" and try to finish the scope.
Cause
When BPA or iRPA are provisioned, a service request is created to verify the need to provision the other system instances required for the setup (for example, and IAS tenant).
As this service request is not completed instantaneously, further changes in BPA/iRPA scoping are blocked until all open service requests are completed.
Resolution
You can check the status of the service requests by following the below steps:
- Go to the Service Control Center work center.
- Enter the Service Requests view.
Here you can search for the most recent service request with ID BYD_ML_SPA and check the status.
Once the status is completed, you should be able to proceed with scoping changes for iRPA/BPA.
Keywords
Robotic Process Automation, Build Process Automation, Machine Learning , KBA , AP-ML-RPA-PRV , ByDesign - Robotics process Automation - Tenant Provisioning , Problem