Symptom
Unable to figure out how the 'Technically Completed' date (TECO) is determined for provider contract revenue recognition scenario.
Environment
SAP S/4HANA Cloud
Cause
Firstly, the system verifies whether the provider contract item is cancelled or not:
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If it is cancelled, then the TECO date is set to the end date of the actual period used for the period-end closing.
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If it is not cancelled, then the system compares the duration date of the provider contract end data and the posting date:
1) If the end date of the duration period of the contract item is not lower or equal to the end date of the actual period used for the period-end closing then TECO is not set.2) If it actually is lower or equal then:
i. If there is no billing plan then TECO status is set and TECO date is set to end date of the contract duration.
ii. If there is a billing plan and the billing plan’s maximal/end date is bigger than the end date of the contract then final evaluation against the end date of the actual period used for the period-end closing is made. If the billing plan’s maximal/end date is bigger than the date used for the period-end closing then TECO is not set. Otherwise if it is lower or equal, than TECO is set and TECO date = Billing plan max date.
Resolution
Kindly go though the logic and make sure the TECO status refer to the expected date and revenue be cleared in a expected period.
Keywords
Period end closing, technical completion, TECO, technically completed, revenue recognition, provider contract, completed status, run revenue recognition. , KBA , CO-PC-OBJ-EBR , Event-Based Revenue Recognition , Problem