Symptom
Admins received an email for the cancellation of onboarding (trigger: (ONB) Onboarding Cancelled Trigger) however these emails are not visible in Admin Center > Email Services.
The onboarding process is still open and onbordee visible in the onboarding dashboard.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Admin received email with trigger "(ONB) Onboarding Cancelled".
- Admin checks Admin Center > Onboarding Dashboard for the candidate mentioned in the email.
- Onbordee profile is still visible and the onboarding process is still open.
- Admin checks Admin Center > Email Services.
- The email received is not there.
Cause
- The archival job triggered the onboarding cancellation, however the cancellation job failed.
- Onboarding process close job updates multiple onboarding processes in batch.
- When process cancellation fails for any of the processes in the batch, the whole transaction is stopped. Cancellation emails are sent asynchronously, for this reason emails are still getting received.
- The emails that we see in Admin Center > Email Services, are dependent on the MDF object: Email Message.
- However, since the batch transaction was reverted, the objects created as part of this transaction (in this case: the email messages objects) are also reverted and not saved into the DB.
- For this reason these email messages are not visible in Admin Center > Email Services.
Resolution
To stop receiving these emails, kindly make sure that Onboarding is cancelled successfully for the affected onbordees.
You can try to cancel onboarding manually via,
- Onboarding Dashboard.
- Affected candidate > Actions.
- Cancel Onboarding.
Keywords
Email not visible, (ONB) Onboarding Cancelled trigger, multiple cancelled onboarding emails , KBA , LOD-SF-OBX-EML , Notifications , Problem
Product
SAP SuccessFactors Onboarding