Symptom
When trying to delete a folder with several content in it, directly in the iContent, the system is not allowing it, throwing the message "Insufficient Permissions".
Environment
Reproducing the Issue
- Access the iContent >
- Search for the folder to be deleted >
- Select it and hit the deletion button >
- System returns a fail message message >
- When checking more details, the system shows "Insufficient Permissions [Folder Name].
Cause
There is a limit of 248 characters for Windows paths. If the user has all the required permissions, it is possible that the folder cannot be deleted due to reaching this limit.
Resolution
Submit a case to SF Technical Support for assistance with deleting a folder in the Learning (LOD-SF-LMS-PCM) component. The processor will contact the SF Operations team to verify if the user has the required authorizations. Additionally, they will investigate if the character limit is causing any problems with deleting files and folders.
The SF Ops team can help with the deletion process with the customer's written permission, in the below format:
"I [Approver Name], from company [Company Name] request your assistance in deleting the folder [Folder Name] located at: [Folder Path]"
See Also
Keywords
Insufficient, Permissions, access, denied, folder, folders, file, files, icontent, delete, eliminate, deletion, remove, user, 248, characters, Windows, paths, path, limit, , KBA , LOD-SF-LMS-PCM , iContent , LOD-SF-LMS-ADM , System Admin, Global Variables, References , LOD-SF-LMS , Learning Management System , Problem