SAP Knowledge Base Article - Public

3464028 - I-9 flow wasn't triggered after the candidate completed the Personal Data Collection - Onboarding

Symptom

After new hire completed Personal Data Collection, US compliance form generated but I-9 Section 1 didn't trigger.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Onboarding was initiated for the new hire;
  2. The New Hire Data Review step and Personal Data Collection step were completed;
  3. US compliance form has been generated for the new hire, in BPE Monitor Process, [compliance.Onboarding2ComplianceIntegration], ''call I9'' Service Task also created, but I-9 flow did not get triggered.

Cause

BPE service user permission issue.

For SAP Support, please refer to the internal memo.

Resolution

1. The Service User you have set up in the 'Update Process Flows for Onboarding and Offboarding' page should be an Onboarding Administrator user. Please grant below permissions to the permission role, otherwise the I-9 flow will not be triggered:

  • Employee Central API > Employee Central HRIS OData API (read-only)
  • Employee Central API > Employee Central Foundation OData API (read-only)

Verify other permissions have been enabled for the administrators: Role-Based Permissions for Administrators in Onboarding and Offboarding

2. Then restart onboarding for the impacted candidate.

Keywords

I-9, I-9 section 1, I-9 flow, I-9 compliance, I-9 form, US compliance, compliance flow, sign I-9 , KBA , LOD-SF-OBX-I9 , i9 Compliance Form , Problem

Product

SAP SuccessFactors Onboarding all versions