Symptom
- Users are not able to log in even after password reset. Getting error after clicking log in:
Fingerprint: e6f3bc26d091c025b8c9be4f211f20ef81dd4c7c
The requested operation is not available. - Users are not syncing from SF to IAS through IPS. The following error is appearing:
error=Source path: $.personKeyNav.userAccountNav.username is not available in content, but is required in defined system transformation Caused by: Source path: $.personKeyNav.userAccountNav.username is not available in content, but is required in defined system transformation Caused by: Expected to find an object with property ['username'] in path $['personKeyNav']['userAccountNav'] but found 'null'. This is not a json object according to the JsonProvider: 'com.jayway.jsonpath.spi.json.JsonSmartJsonProvider'
Environment
SAP SuccessFactors HCM Suite
SAP Cloud Identity Services – Identity Provisioning IPS
Reproducing the Issue
- Reset user password as an admin
- Logout
- Try to login with user new password
- Error: The requested operation is not available.
Cause
- Check Tool User Account Management -> No account data is missing. will show errors for those users
- Person id and Account UUID cannot be null
Resolution
- Run Check Tool
- Filter for User Account Management -> No account data is missing. (AccountDataMissingCheckExecutor)
- Run check
- Use Quick Fix to update the missing accounts with data in the Expected Login Name column
See Also
Keywords
e6f3bc26d091c025b8c9be4f211f20ef81dd4c7c, AccountDataMissingCheckExecutor, check tool, quick fix, No account data is missing, The requested operation is not available, login error, userAccountNav , KBA , LOD-SF-PLT-PWD , Password Policy Settings & Reset Password , Problem
Product
SAP SuccessFactors HCM Suite all versions