SAP Knowledge Base Article - Public

3464179 - Knowledge Base Widget is not Working in Agent Desktop (Add-on)

Symptom

  • Knowledge Base integration with C4C has been carried out per the SAP Help Portal documentation
  • When testing the Knowledge Base Widget from the Agent Desktop, users get the following messages:
    • KB Articles Unavailable.
    • Can't connect to knowledge base.
    • Ensure that knowledge base settings are correct, and that your provider's service is available.
  • Agent Desktop SBS (Side-by-Side) mode.

Environment

Reproducing the Issue

  1. Go to Service
  2. Click on "Agent Desktop"
  3. Search for a Business Partner and confirm it
  4. Click on the Knowledge Base tab

Cause

Missing configuration

Resolution

  1. Ensure following the all the Knowledge Base set up document and that the provider details are correct (if this information is incorrect, connection failures will occur):
    • User - user name for account
    • Key
    • Secret
  2. Ensure the "Create Communication Systems" and "Configure Communication" are also completed.
  3. Ensure a test is performed to confirm the KM provider endpoint can be reached:
    1. Go to Administrator
    2. Navigate to Service and Social
    3. Launch "Configure Agent Desktop" and go to "Communication Configuration"
    4. Locate and open the Communication Configuration instance defined for this integration and open it
    5. Scroll down to "HTTP Data", where there should have been two connections defined, select them and click on the Globe+arrow icon to test.
      • Check for any errors
      • If there are errors, continue investigation.
      • Typical error would be something like:
        "Communication "XYZ123" is not configured with outbound communication system."
      • For this you will need to:
        1. Navigate to "Communication Systems", from the same Agent Desktop Admin screen
        2. Click on the pencil to edit the corresponding Communication System
        3. Ensure the Outbound Hostname is correctly maintained.
          • For example, sapdemo-responsive.mindtouch.us. 
          • The above needs to be specific to the KBA System endpoint.
          • Consult your provider for details.

Keywords

Knowledge Base Setup, Provider Details, User, Key, Secret, Communication Systems, Configure Communication, Test, KM Provider Endpoint, Administrator, Service and Social, Agent Desktop, Communication Configuration, HTTP Data, Errors, Outbound Communication System, Consultation. , KBA , LOD-CRM-SBS-AC , Agent Console Add-on , Problem

Product

SAP Cloud for Customer core applications 2402