Symptom
You are trying to synchronize accounts and contacts in ByDesign system to Outlook Add-In, however, this information is not synchronized in the Outlook Add-In.
Disclaimer: "Images/data in this KBA are from SAP internal systems, sample data or demo systems. Any resemblance to real data is purely coincidental"
Environment
SAP Business ByDesign
Reproducing the Issue
- Log on to the ByDesign system from outlook client using the outlook add-in.
- Go to Settings
- Navigate to Contacts
- Select Download Contacts
- Notice, the Contacts and Accounts are not synchronized
Cause
Contacts are not synchronized with the Outlook add-in because the contact information is not maintained in the Business ByDesign system.
The account is not synchronized because Groupware Synchronization is not scoped in the system.
Resolution
As a pre-requisite for downloading contacts to Outlook from SAP Business ByDesign, the Groupware Synchronization checkbox provided in the Account Management work center, needs to be selected.
You can subscribe to groupware synchronization of contacts in Outlook only if Responsibilities for Contacts business option is selected in your solution configuration. Follow the below steps to scope the question:
- Go to the Business Configuration work center
- Choose the Implementation Projects view
- Edit Project Scope
- In the Scoping step of the project, ensure that Business Partners is selected within General Business Data
- In the Questions step, expand the General Business Data scoping element and select Business Partners
- Select Handling of Business Partners and answer the question, Do you want to maintain direct responsibilities for contacts? Responsibilities for Contacts
Follow the below steps for Account Synchronization:
- Go to Account Management workcenter
- Go to Accounts view
- For example, go to Account ID: 1002661
- Account created/ already existing, must have the relationship with Contact which should it get synchronized with.
- Select Edit and View All
- Navigate to the Contacts tab
- Navigate to the sub tab Contacts
- Select Assign Contact. Note: The Contact must be assigned via ‘Assign Contact’ button
- Select the value help and choose the contact
- Save
Follow the below steps for Contact Synchronization:
- Go to Account Management workcenter
- Go to Contacts view
- For example, the Contact ID: 1002640 is taken for demonstration:
- Select Edit and View All
- Navigate to the Relationships tab
- Navigate to the sub tab Responsibilities
- Select Add Row and maintain the Employee/Customer detail on whose Account the contact needs to be replicated to Outlook
- Select the Party Role as "Additional Contact Responsible"
- Save
To Synchronize the Contact/Account in Outlook, follow the below steps:
- Now, go to Outlook Add-In
- Login to BYD logon
- Go to Settings
- Select Synchronize Contact Automatically checkbox as seen in the below screenshots and select OK
- This will synchronize both the Account and Contact information in Outlook
Note:
- Account thus synchronized can be checked via Email Sync pop-up function and all the Account related to the Customer can be seen /searched (as shown in screenshot above).
- Contact synchronized will be available under My Contact -> In Outlook.
See Also
Keywords
Contacts, Accounts, Outlook Add-In, Synchronize issues, Contact Responsible, Account Management , KBA , SRD-CC-OIN-GW , Groupware , Problem
Product
Attachments
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