SAP Knowledge Base Article - Public

3464250 - Can not get completed calibration session record via API - Calibration

Symptom

When retrieving calibration to do records via TodoEntryV2, notice that completed calibration records ("status": 3 ) do not show in the result.

Environment

SAP SuccessFactors Calibration

Cause

This is current expected behavior.

Resolution

It is current module design that the calibration session to do record will be removed when the session is finalized/completed. In other words, the API only returns calibration sessions that are in progress ("status": 2).

Workaround

As a workaround, you can query the user's in progress calibration to do tasks and compare the results to check which session has been completed. For example, if a previously existing session to do record is not returned in the latest query, it means the session has been completed.

You can also add filters to check if specific calibration session has been completed. For example, you can add "categoryId" (for "complete calibration" task, the corresponding category id is 12) and "subjectId", which is the calibration session id, in the query. If the result returns empty, it means this calibration session has been completed. 

Note: in calibration to do, "subjectId" is the calibration session id while "userId" is the user id of the task owner.

See Also

KBA Reference

Keywords

calibration, api, to do, TodoEntryV2, completed session, finalize, query, calibration session, categoryId, subjectId, userId, status , KBA , LOD-SF-CAL-POD , Home Page, Pods and Portlets, To Do List , LOD-SF-CAL-API , Webservices, OData APIs , How To

Product

SAP SuccessFactors Performance & Goals all versions