SAP Knowledge Base Article - Public

3464616 - Workflow With Warranty ID Matches Pattern Not Working For Ticket

Symptom

You defined a workflow to look into a ticket and consider the pattern of the warranty ID field of it. Despite what you are seeing in ticket, pattern does not match and workflow does not trigger.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Service work center.
  2. Open the Tickets work center view.
  3. Open ticket ABC (where ABC is the ID of a ticket).
  4. Change the warranty field to DEF (where DEF is a value that matches pattern you set in your workflow).

Workflow does not trigger. 

Cause

Warranty ID means the ID of Warranty, a number; In ticket, however, you may be seeing the Warranty name instead which can cause confusion.

Resolution

This is the current system standard behavior.

Keywords

Workflow, Warranty, ID, Matches, Pattern, Not, Working, Ticket, Wrong, Trigger , KBA , LOD-CRM-WKF , Workflow , LOD-CRM-SRP , Service Request Processing , How To

Product

SAP Cloud for Customer core applications 2402