Symptom
- You are using Agent Desktop (add-on)
- You are using a Widget base integration
- When an inbound call is accepted, the expectation is that the phone call interaction would be created
- No interaction is created even when there is no errors shown
Environment
- SAP Cloud for Customer core applications
- Agent Console Add-On for SAP Service Cloud
Reproducing the Issue
- Initiate an inbound phone call
- Accept the call via the CTI widget
- Call is accepted, but no attempt to search in AD was performed and no interaction was created
Cause
- Missing configuration
- Invalid or incorrect payload from CTI
Resolution
- Ensure the CTI is sending the correct payload per the "Phone Integration" online documentation
- Ensure that the Communication Systems has been created and configured in for the Agent Desktop:
- Setting up the communication system:
- Go to Administrator
- Navigate to General Settings -> Communication Systems
- Create a New entry if non already exists (for this example, we would say the name of the Communication System ID is "CTI")
- Maintain the entry as:
- ID= CTI
- Hostname= CTI
- System Access Type= Internet
- Under Business Instances, create one entry and fill the system ID as "CTI" and the Preferred Application Protocol as "5-Web Service"
- Save the changes and activate
- Configure the Agent Desktop to use the above Communication System:
- Go to Administrator
- Navigate to Service and Social
- Open Configure Agent Desktop and navigate to "Configure Widget and Provider"
- Enter "CTI" under Communication System ID
- Save the changes, restart the browser session and test
- Setting up the communication system:
See Also
- 3252554 - Error "Failed to create interaction, please contact your administrator in Agent desktop" after accepting a phone call
- 3290081 - Failed to create interaction, please contact your administrator, when answering a phone call from the Agent Desktop
- 3382248 - External ID and Original External ID are not copied to the Phone Call Activity
Keywords
Agent desktop, Agent Console, Interaction Records, Search, Side by side, add-on, activity, creation, customer hub , KBA , LOD-CRM-SBS-AC , Agent Console Add-on , Problem
Product
SAP Cloud for Customer core applications 2402