Symptom
- User is not able to approve/decline/update a workflow in SF Mobile App
- When trying to approve a custom MDF workflow at SF Mobile App, system displays the error message: "Failed to process your response. Please try again later."
- Even if there is a custom error message created for a custom MDF workflow approval, the custom message displays correctly on web/browser versions, but on mobile still the default message will be shown.
Environment
-
SAP SuccessFactors HCM Suite
-
Metadata framework (MDF)
- SAP SuccessFactors Mobile
Reproducing the Issue
- At SF browser
- Go to "My pending requests" on web
- Find the request for a custom MDF workflow
- Try to approve and get the custom error that was configured for this workflow or the workflow will get approved as expected
- Login to mobile
- Go to To-Do
- Find the request for a custom MDF workflow
- Try to approve and get the error: "Failed to process your response. Please try again later"
Cause
This is an expected behavior as per system designed.
Resolution
As per system design, custom MDF workflows can't be approved/declined/updated via SF Mobile App.
Within this logic, it is by design that the mobile UI will show the general error message after clicking any action (approve/decline/send back/...) on the workflow, even if there is a custom error message pre-configured.
See Also
Keywords
successfactors, mobile, MDF, custom MDF, rule, business rule, custom rule, error message, error, workflow, approve, metadata framework, Failed to process your response. Please try again later, , KBA , LOD-SF-PLT-MOB , Mobile Issues , LOD-SF-MDF , Metadata Framework , LOD-SF-MDF-WFL , Custom Object based Workflows , LOD-SF-MDF-RUL , Custom Oject based Business Rules , Product Enhancement
SAP Knowledge Base Article - Public