Symptom
Cloud Applications Studio (Pilot) freezes while Debugging.
Environment
SAP Cloud for Customer core applications
Reproducing the Issue
Steps to reproduce from the frontend
- Navigate to Woc XYZ
- Open any ticket
- Make a demo change on the field for the debug to trigger.
Steps to reproduce from the SDK (Cloud Application studio)
- Login to the SDK with the technical user ID.
- Open the absl which needs to be debugged.
- Add the break point on the absl file.
- Activate the debug.
- Perform the frontend steps to trigger the breakpoint.
- Once the debug triggers the SDK freezes or crashes.
Cause
The issue occurs because there is restriction in the SAP backend for PDI technical user.
If the PDI technical user password length is more then 40 characters and if same user is performing an debug on Cloud Application Studio then the Studio will crash.
Resolution
If you are using any PDI technical user to debug the script then the maximum length of the password of that user is supposed to be within 40 characters.
Keywords
KBA , AP-RC-BDS-SOL , ByDesign Studio Solution Explorer , Problem