SAP Knowledge Base Article - Public

3466294 - Cloud Applications Studio Freezes While Debugging and Restart Every Time

Symptom

Cloud Applications Studio freezes while Debugging.

Environment

  1. SAP Cloud for Customer core applications 
  2. SAP Cloud Applications Studio

Reproducing the Issue

Steps to reproduce from the frontend

  1. Navigate to Woc  XYZ
  2. Open any ticket
  3. Make a demo change on the field for the debug to trigger.

Steps to reproduce from the SDK (Cloud Application studio)

  1. Login to the SDK with the technical user ID.
  2. Open the absl which needs to be debugged.
  3. Add the break point on the absl file.
  4. Activate the debug.
  5. Perform the frontend steps to trigger the breakpoint.
  6. Once the debug triggers the SDK freezes or crashes.

 

Cause

  • The issue occurs because there is restriction in the SAP backend for PDI technical user.
  • If the PDI technical user password length is more then 40 characters and if same user is performing an debug on Cloud Application Studio then the Studio will crash.

Resolution

If you are using any PDI technical user to debug the script then the maximum length of the password of that user is supposed to be within 40 characters.

Keywords

Cloud Applications freezing, debugging crash, SAP backend restriction, PDI technical user issue, password length limit, SDK crash, SAP Cloud for Customer, ByDesign Solution Explorer, debug breakpoint issue, frontend debug trigger, absl file debug, technical user password issue, SAP backend limitation, SDK freezing issue, debugging resolution , KBA , AP-RC-BDS-SOL , ByDesign Studio Solution Explorer , Problem

Product

SAP Business ByDesign all versions ; SAP Cloud Applications Studio all versions