Symptom
- After importing Phone Calls via Data Import, the start and end times are changed by x amount.
- The uploaded attached file shows that everything except the date/time is correct.
- The time defined in the Excel file is X number of hours earlier or later than the time of the call entry.
Environment
- SAP Service Cloud Version 2 1.0
- SAP Sales Cloud Version 2 1.0
Reproducing the Issue
- Go to and logon Service Cloud V2
- Settings -> Go to Data Import and Export
- Click Import -> Create -> Entity = "Phone Calls"
- Select the file maintained per the template
Cause
- System is working as designed
- Ensure the data is prepared per specifications and data is for example, 2021-12-31T23:59:59Z. Enter the UTC time.
- Since Service Cloud does not know the actual time zone the calls were logged in, the data which was imported will always refer to GMT/UTC time.
- By default, the conversion would be done based on the user's browser localization settings
- The end user UI displays time as per the time zone of the user.
Resolution
- Ensure that the time zone settings are consistent between the Excel file and the system, to consider the time offset.
- Verify that the date/time format in the Excel file matches the format expected by the system.
- Double-check the time zone settings in the system to ensure accuracy.
Keywords
Service Cloud, time zone, calls, logged, imported data, GMT time, wrong time, time offset, Zulu, time conversion , KBA , CEC-CRM-PH , Phone Calls for SAP Sales/Service Cloud , Problem
Product
SAP Sales Cloud and SAP Service Cloud Version 2 1.0