Symptom
In apps Manage Journal Entries - New Version F0717A and Manage Journal Entries - Old Version F0717 attachments do not appear visible.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open Manage Journal Entries app F0717A or F0717.
- Open a sample Journal Entry.
- No attachments displayed.
Cause
In Manage Journal Entries app, we use the S/4HANA Attachment Service component to handle the attachments of the journal entries. It is designed so it can be used across other applications. The logic is slightly different in comparison to SAP GUI logic. The Attachments Service for S/4HANA has a concept, that it only supports one object type at a time. Therefore, the system will only display attachments uploaded directly to journal entry itself, and not the attachments coming from e.g. Incoming Invoice.
Resolution
Manage journal Entries can only display attachments uploaded from 'Post General Journal Entries', and 'Manage Journal Entries' itself.
In most cases, the work-around in the Manage Journal Entries app is as follows:
- Click the 'Related Documents' tab of the document, click on the invoice hyperlink.
- The system will redirected to either 'Display Supplier Invoices' or 'Display Process Flow - Accounts Payable'.
- The attachment can be reviewed in these two applications.
See Also
Keywords
Manage Journal Entries, MJE, manage, journal, entries, app, fiori, park, post, parked, posted, attachment, attachments, entry, display, missing, visible, displayed, F071, MJEv2, SAPGUI, FB03 , KBA , FI-FIO-GL-TRA , Transaction Apps , FI-FIO-GL-IS , Reporting Apps , Problem