SAP Knowledge Base Article - Public

3466904 - Tickets Created With Default Account Although An Active Contact Is Maintained

Symptom

Sending an E-mail to the E-mail channel is creating Tickets with Default Account maintained in the channel although the sender of the E-mail is maintained as an active Contact in the system and is assigned to an active Account.

Environment

SAP Cloud for Customer

Reproducing the Issue

Pre-Requisite: 

  1. An Active Contact with E-mail address abc@def.com is maintained and is associated with an Active Account XYZ (abc@def.com is the Contact E-mail address and XYZ is the Account name)
  2. An Active E-mail Channel with a Default Account is maintained

Steps:

  1. Send an E-mail to the Active channel from the E-mail maintained as Contact.
  2. Go to Service Work Center.
  3. Go to Tickets View.
  4. Open the new Ticket 123 (123 represents the Ticket ID created from E-mail).
  5. On the Overview see that the Customer determined is the Default account. 
  6. But you expected the Account to be XYZ which is associated to the Contact.

Cause

The Sender E-mail address is maintained for more than one active Contact in the system. If the e-mail is associated to more than one active Contact the system will not recognize from which Contact the e-mail needs to be taken from and hence use the Default Account set for the e-mail channel.

Resolution

An E-mail should be linked to only one active Contact. If multiple active Contacts or no active Contact is found then the system creates a Ticket with the Default Account maintained in the E-mail channel. This is system expected behavior.

Delete the E-mail from the duplicate Contact(s) and maintain only one active Contact with the E-mail abc@def.com so the system can create Ticket with the Account associated to this Contact.

You can delete the E-mails from the Contact by:

  1. Go to Customer Work Center.
  2. Go to Contacts View.
  3. Search using "abc@def.com".
  4. See the list of Contacts in the results.
  5. Open the Contacts one by one and in the header section clear the E-mail address maintained as "abc@def.com".
  6. Save.

Keywords

KBA , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer core applications all versions