Symptom
LMS Admin changes the Maximum Enrollment of a Class from a number to blank (unlimited seats) but waitlisted Users are not getting auto enrolled into the Class.
Environment
SAP SuccessFactors LMS
Reproducing the Issue
- Navigate to System Admin > Classes -> Search for a Class
- Select Class to edit
- Go to Class Details page, make sure "Auto Enroll from Waitlist" in the section of "Registration Settings" is ticked on
- Remove number from Maximum Enrollment making the number of seats unlimited
- Observe how no window pops up with system asking “Auto fill available seats” or “Do not auto fill available seats”
Cause
When an Admin updates the Maximum Enrollment to a certain number (greater than the number of already enrolled Users in the Class) from null or a smaller value, the Admin is presented with a window asking if they want to auto fill the seats from the waitlist.
This window does not come up when the Admin sets the maximum enrollment to blank.
Resolution
This scenario is working as expected.
Admins are advised to use a number value to trigger the auto enrollment from the waitlist, as that option won't appear when the limit is removed (set to blank).
See Also
2476525 - LMS: Enable Auto Enroll from Waitlist in Class
3049033 - The user selection logic of "Auto Enroll from Waitlist" function
3421984 - Auto Enroll from Waitlist does not automatically move users from waitlisted to registered
Keywords
LMS, Class, Enrollments, Auto enroll, Waitlist, Seats , KBA , LOD-SF-LMS-SCH , Class - Scheduled Offerings , Product Enhancement