Symptom
An interface creates individual customers via OData. When checking this record in C4C, the Created by field is named "Technical User". However, filtering the individual customer OWL to see all customers created in this manner is not possible as 'Technical User' is not available as a filter.
Environment
SAP Cloud for Customer
Reproducing the Issue
1. Create a document via OData using your integration. (Let's say the user used on the integration is "ABC")
2. Open the object in C4C.
3. Check on the header, the field Created By.
4. It is filled as "Technical User".
5. Go to OWL screen.
6. Try to search for "Technical User".
7. You can't find "Technical User" neither the technical user "ABC" used in the integration.
Cause
You need to know that for technical users, no related Employee person exists which carries the name information of this change identity.
For that reason, we have exit implementations to populate this in OData/OWL to see at least who was the change user.
Nevertheless, this exit implementations can only cover the retrieval part, but not the query part as a query would require to have that information as persistent data.
As this is not the case with the object 'Identity' carrying that information, it can't be consumed in SADL based queries like OWL or OData.
Resolution
You can see the technical user name, but you can't query on it.
This must be considered as limitation.
See Also
Keywords
OData; Technical User; Filter; OWL; Search; Created By , KBA , LOD-CRM-INT-API , OData API (C4C Only) , How To