SAP Knowledge Base Article - Public

3467816 - Error message "Customer * is not defined in company code XXXX" when importing lockbox

Symptom

Error message "Customer * is not defined in company code XXXX" is raised in the log in Reprocess Lockbox Items app when a lockbox file is imported.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Access the app Manage Incoming Payment Files.
  2. Click on Import.
  3. Select Lockbox Batch.
  4. Upload the lockbox file.
  5. Click on Process.

Cause

The system is not able to uniquely determine/identify customer account based on MICR number, or the invoice number (document number/reference number) provided in the lockbox file. In the context of lockbox processing, MICR numbers refer to the combination of Transit Routing Number (Bank Key) and Customer Bank Account Number.

Resolution

Lockbox needs a MICR number or a journal number to identify a specific customer. It first looks at MICR number to determine the customer account. Ideally, it will be good if both (MICR & journal entry number) are provided in order for Lockbox to be able to perform clearing in Accounts Receivables. Record 6 in the lockbox file contains the customer's bank account number. It is a combination of Bank Key and Bank Account Number. This information needs to be updated in the customer master data.

Follow the below steps to maintain the bank account in the customer master data:

  1. Access the app Manage Customer Master Data.
  2. Go to the tab Bank Accounts.
  3. Click on Create.
  4. Maintain the Bank Country, Bank Key and Account Number.
  5. Click on Save.

Note: For intercompany clearing using lockbox, it is required to maintain the bank accounts in the customer master data to identify the customer account correctly. 

See Also

Format Description for Lockbox Batches

Lockbox with BAI Format

Intercompany clearing of lockbox items using Processing Rules

Keywords

F5102, Upload Lockbox Files, FLB2, Lockbox, Bank Account, FI-BL-PT-LB, FI-BL-PT-US, US, USA, CA, Canada, Intercompany , KBA , FI-BL-PT-LB-2CL , Automatic Lockbox Processing (Public Cloud) , FI-BL-PT-US-2CL , US-bank statement/lockbox (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions

Attachments

Pasted image.jpg
Pasted image.jpg
Pasted image.png