Symptom
You are trying to add templates created as responses to an email and then an error message appears:Unable to add a template.
Environment
- SAP Service Cloud Version 2
- SAP Sales Cloud Version 2
Reproducing the Issue
- Open Service Cloud V2
- Go to Leads
- Open any Lead
- Navigate to Activities and then click New
- Choose Email
- Click Add Template
The following error appears: Unable to add a template.
Cause
- Email Template Configuration issue
- Typically, this issue is caused by the use of incorrect place holders in the response templates.
Resolution
- Click on the User Menu.
- Click Settings.
- Navigate to All Settings.
- Click Templates under Emails.
- Click +.
- Look for the responsible template you are facing the issue.
- Navigate to the Placeholder tab.
Make sure the placeholder you added to the response template is on the standard list that will be used. Even if the placeholders had been copied and pasted with the same name, the problem would remain. Check that there are no spaces or erroneous characters in the HTML file by following an extra tutorial in Notepad++ tool.
- Open the Notepad++.
- Click in Edit button.
- Navigate to Line Operations option and then apply the following options.
- Remove empty Lines
- Remove empty lines ( containing blank characters )
- Remove duplicate lines
See Also
- KBA 3434774 - Placeholder in Email Template is not populated with Desired Value
- KBA 3347427 - Unable to See Text Content Added to Email Body when Using Templates in Cases
- Configure Email Templates
Keywords
Unable to add a template,Response template, Template, Placeholder, HTML , KBA , CEC-CRM-TMP , Templates for SAP Sales/Service Cloud , Problem