Symptom
Instantiation Lock on Pdi solution when activating approval process following solution clean
Environment
- SAP Cloud for Customer
- SAP Business ByDesign
- SAP Cloud Application Studio
Reproducing the Issue
- Perform a clean of a PDi solution
- Attempt to activate an approval process in your solution example: /Y1234567Y_MAIN/SRC/CustomObject/Object-Root-ApprovalStatus.approvalprocess
Errors are raised similar to below:
- Errors in the create action condition of action rule 'APP1_NTF_APPR_ACTRULE'
- Instantiation lock flag is set for task type used in action rule 'APP1_NTF_APPR_ACTRULE'
Cause
This is a known issue following a solution clean
Resolution
SDK activation required of the BO that the approval process is based on - this should resolve the issue. If it does not please raise a case providing all details and permission to activate all affected BOs and approval processes on SAP side.
Keywords
Instantiation lock, Pdi, Failed activation, approval process error , KBA , AP-RC-BDS-BO , ByDesign Studio BO definition/generation , Problem
Product
SAP Business ByDesign 2405