Symptom
Candidates are getting their IAS account deleted after onboarding process is restarted. They are no longer able to access SuccessFactors.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Log into system
- Initiate onboarding
- Onboardee receives notifications from IAS and was able to authenticate and create an IAS profile
- Log in and proceed with onboarding
- HR user restarts onboarding
- IAS profile is deleted after onboarding is restarted
Cause
A custom process variant is being used, but it was not deployed still.
Resolution
Once we take a look on KBA: 3281873 - [Onboarding] IAS Main KBA - SAP for Me we have the following points:
- If custom Process variant is used, then Process variant Manager needs to be deployed with latest xml and should have the IAS code.
- Ensure that the onboardee has completed New hire data review step
As users have already completed the NHDR step, but, candidates extension status is still equal to 2:
(how to check it: Data Inspector > Table_USER_ACCOUNT > Username > Check what is the Extension Status)
- 2 - Pending (Do not sync to IAS as New hire is not yet ready to sync to IAS.)
Example - "New hire data review step" is Not completed to proceed with next step by New hire "provide personal data collection".
The next point is to check what is the Process Variant assigned to the candidate, if it is a custom one:
- Go to 'Process Variant Manager' select "Default Process" > Save and validate Process Variant > Activate it again
- Now go to 'Update Process Flow for Onboarding' > Select the service user > Update it again
In order to correct this for affected candidates, restart their process again, so IAS can be fixed.
See Also
Keywords
missing, profile, IAS, account, delete, remove, after, onboarding, process, restart, restarted, candidate, login, process, variant, custom, OBX, 2.0 , KBA , LOD-SF-OBX-IAS , IAS User Authentication , Problem