Symptom
Status not mapped in the status schema, but available in the Status Filter List.
Environment
SAP Sales Cloud and SAP Service Cloud Version 2.
Reproducing the Issue
- Log on to your SAP Service Cloud Version 2 environment.
- Click on the User Menu.
- Click Settings.
- Navigate to All Settings.
- Click Party Schema under Cases.
- Select any standard or a custom party schema.
- In the actions column, click on the View Status Schema.
- Navigate through the Assign Status Schema session and then hide the respective status from the schema.
- Go to the cases.
- In the status Filter, check the status that you have set as hidden.
- All the statuses are still visible.
Cause
The case list is a concatenated list of statuses from all status schemas, mapped to the different case types. Removing an inactive status may cause the case list to become inconsistent, as the status may have previously been applied to a case.
Resolution
This is the system's behavior; However, the development team is working on finding a more efficient approach to displaying statuses on the list in the next releases, but at the moment, it is not possible to commit or confirm a timeline.
Keywords
KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , Product Enhancement
SAP Knowledge Base Article - Public