SAP Knowledge Base Article - Public

3469587 - Error with Competencies and behaviors are successfully migrated to Talent Intelligence Hub (Check ID: JdmToWsmPostMigrationWsmIdsNullCheck) - Job Description Manager

Symptom

When running the checks for the Job Description Manager application in Admin Center > Check Tool, issue(s) for the check "JdmToWsmPostMigrationWsmIdsNullCheck" are found.

Environment

  • SAP SuccessFactors Job Description Manager
  • SAP SuccessFactors Talent Intelligence Hub

Reproducing the Issue

  1. Log into SuccessFactors
  2. Navigate to Admin Center > Check Tool
  3. Select the Migration tab
  4. JdmToWsmPostMigrationWsmIdsNullCheck has errors

Cause

  • The environment has Job Profile Builder enabled
  • Job Description Manager issue

Resolution

This check can only be resolved by engineering when Job Profile Builder has not been enabled. Some customers have the Job Profile Builder appearance but the system is recognized as being on Job Description Manager. You can follow the below steps to determine if the migration has taken place:

Determine if the JDM to JPB Migration has taken place

  1. Log into SuccessFactora
  2. Navigate to Admin Center > Scheduled Job Manager
  3. Select the Job Monitor tab
  4. Locate the Job Type dropdown and search for JDM Old to New Sync
  5. The result will not appear

The environment has Job Profile Builder enabled

To complete the migration, please follow the below steps to migrate to JPB and then migrate to Talent Intelligence Hub:

  1. 2276692 - Best Practices on JDM to JPB Migration
  2. 3328015 - Migrating JPB data to Talent Intelligence Hub - 1H 2023

Job Description Manager issue

Engineering will need to process a script to correct the data. Please create a case with Product Support under component LOD-SF-TIH-MIG and provide the following required details:

  • Picture showing all other check tool errors are resolved
  • Data Center (URL of your login screen):
  • Company Instance ID (where to apply changes):
  • Approval

Still Need Help?

If you need assistance with the migration, customers can exchange experiences with each other and ask questions of our migration and adoption experts in a new Work Zone group. In order to be admitted into the group, please send an email to SAP_SF_Product_Advisory@sap.com. All group members will also be invited to Office Hours calls, that will take place from time to time, and according to necessity. More information is posted in Everything you need to know about: SAP SuccessFactors Talent Intelligence Hub.

See Also

Keywords

JDM, TIH, migration, errors, migration issues, errors, failures, migrating, failed , KBA , LOD-SF-TIH-MIG , Migration to Talent Intelligence Hub , LOD-SF-TIH-JDM , Job Description Manager , Problem

Product

SAP SuccessFactors HCM Suite all versions