SAP Knowledge Base Article - Public

3469612 - Picklist values in Data Capture Forms is not visible - Recruiting Marketing

Symptom

When create a new Data Capture Form with some custom picklist fields, the drop-down list of these fields is appearing empty.

Environment

SAP SuccessFactors Recruiting Marketing

Reproducing the Issue

  1. Go to a Data Capture form on the career site
  2. Click on the field that have drop down 
  3. Any value appears to be selected.

Cause

There are three possible causes why the values are not visible:

  • Lack of permission with the specific user/picklist
  • Picklist is set as "Secured" in the Object Definition.
  • Picklist Value is set as "Secured" in the Object Definition.

 

Resolution

Please see the relevant resolution steps below:

  1. Refer to the correct information in the Setup Permission Roles Guide
  2. It is necessary to ensure that all the permissions are correctly configured for the Marketing / DCF to function properly.

    • Go to "Configure Object Definition" page
    • Search for "PickList" object 
    • Click on Take Action and update the "Secured" from Yes to No. Save the changes. 
    • Refresh oData metadata. 
  3. Similarly, it should be ensured that "Picklist Values" is also set to unsecured. 
    • Go to "Configure Object Definition" page
    • Search for "PickList Value" object 
    • Click on Take Action and update the "Secured" from Yes to No. Save the changes. 
    • Refresh oData metadata. 

After this, refresh the picklist in the CSB.

 

Keywords

picklist empty, no values, dcf, picklist, data capture form , KBA , LOD-SF-RMK-CRM , Data Capture Form, Email Layout, Email Campaign , Problem

Product

SAP SuccessFactors Recruiting all versions