SAP Knowledge Base Article - Public

3469676 - CTI Call Alerts Not Displayed in Live Session of Live Activity

Symptom

  • You are using SAP Cloud for Customer Live Activity integrated with the Local CTI Adapter
  • When an inbound phone call is received by the CTI system, the expected behavior is to display the phone number along with caller context information derived from master data.

Environment

SAP Cloud for Customer

Cause

Missing or incorrect configuration

Resolution

  • Ensure the "Scope and Configure Live Activity" configuration has been completed successfully.
  • If you are using or plan to use HTTPS, ensure that you have also properly maintained/create a Self-Signed certificate (see Procedure).
    • Please note this is customer's responsibility to create and maintained.
    • Customers can generate the Self-Signed Certificates wither using their own private CA (Certificate Authority)
    • Note: makecert.exe is deprecated.
  • To Disable HTTPS:
    1. Go to Business Configuration
    2. Implementation Project and select your latest implementation
    3. Edit Scope and navigate (Next) to Questions
    4. Select Service -> Customer Care -> Service Request Management 
    5. Check the question: "Do you want to enable secure communication (HTTPS) for CTI Integration?"
    6. Save changes 
  • If the above is ok, check if there is any BAdi/PDI implementation.
  • If a custom implementation if found, please do one of the following:
    1. Fix the existing implementation or
    2. Delete the solution and upload it back into SAP Cloud Studio, this will triggered a refresh of the Business Configuration.

See Also

  • Help Portal Document: Custom Live Activity Customer Search BAdI Exit
  • Knowledge Base Article:
    • 2881930 - How to Analyze If Calls Reached CTI Adapter
    • 3156554 - CTI Integration Options with SAP Cloud for Customer (Service and Sales)
    • 3264689 - Live Activity: BADI Enhancement for custom fields is not working
    • 2620740 - CTI Adapter Crashing When Launching
    • 3208915 - Live Engagement widget does not load the widget or the telephone icon is missing

Keywords

Scope and Configure Live Activity, HTTPS, SSL certificate, Business Configuration, Implementation Project, Service Request Management, CTI Integration, BAdi, PDI implementation, SAP Cloud Studio, Refresh , KBA , LOD-CRM-LA , Live Activity , Problem

Product

SAP Cloud for Customer core applications 2405