SAP Knowledge Base Article - Public

3469694 - The User ID you have entered was previously used. Please enter a new unique ID.

Symptom

When trying to create a a user with the same ID as a deleted user, the following error appears: "The User ID you have entered was previously used. Please enter a new unique ID."

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors Learning 

Reproducing the Issue

1. Login to Learning Administration
2. Navigate to People -> Users -> Click on "Add New"
3. Fill in the necessary details including the User ID and click on "Add"
4. The error is encountered

Cause

The error occurs when you are trying to create a a user with the same ID as a deleted user

This means that ID was already created and in use at some point of time in the system and would have been deleted. Since you are trying to create a new user with the same ID it is not allowing you to do so .

Resolution

Manual creation of a deleted user is not possible.

Two potential solutions for the same:

* Please Reach out to professional services or a certified partner for assistance in restoring users with these processes*

  • 2392076 - User Permanent Purge feature 
  • 2561639 - Reincarnation of deleted user via user connectors 

Keywords

Successfactors, Learning, User, ID, Unique ID, already been used. , KBA , LOD-SF-LMS-USR , User Entity , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-IMP , Import Data Tool , Problem

Product

SAP SuccessFactors Learning all versions