Symptom
A rule created in Payment Information Detail object to lookup a bank in Manage data based on a field in payment info returns a value for X bank but not for Y bank.
Environment
- SAP SuccessFactors Employee Central
- SuccessFactors HCM suite
Reproducing the Issue
- In the employee profile, navigate to payment information;
- Fill the necessary field to met the parameters to trigger the rule that will lookup for the the bank in Manage Data and set this bank in the bank field in payment information record;
- The rule will trigger but no value will be set for the bank field.
- It was expected to fill the bank field with the Y bank. However, when triggering it with parameters to get the X bank the field will be filled.
Cause
The rule didn't found any bank because there isn't any record with the Y bank for any user in the system.
Resolution
This is the current expected behavior of the system. You can submit an enhancement request specifically about this to have it considered within future development cycles – you can do this on our Customer Community Portal. For detailed steps on How to Submit Ideas for SAP SuccessFactors Products, please refer to KBA 2090228 - How to submit enhancement ideas for SAP SuccessFactors Products - SAP for Me.
See Also
Keywords
lookup, rule, payment information, bank, object, manage data, country, , KBA , LOD-SF-EC-PAY , Payment Information (Bank Information) , Problem