SAP Knowledge Base Article - Public

3470179 - Error with Behaviors are successfully synchronized back from Talent Intelligence Hub. (Check ID: WSMBehaviorMissingInCoCDuringSyncBackCheck) - Talent Intelligence Hub

Symptom

When running the checks for Talent Intelligence Hub application in Admin Center > Check Tool, issue for the check "WSMBehaviorMissingInCoCDuringSyncBackCheck" can be found.

Environment

  • SAP SuccessFactors Talent Intelligence Hub
  • SAP SuccessFactors Center of Capabilities

Cause

Behaviors are not synchronized back to Center of Capabilities

Resolution

I. Determine Which Competency the Behavior is Tied To

  1. Navigate to Admin Center > Tools > Import and Export data
  2. In the Select the action to perform dropdown, select Export
  3. In the Select Generic Object field, select Competency-Behaviors
  4. In the Include Inactive Records dropdown, select Yes
  5. Select Export > View Results
  6. Locate the job and select View Details
  7. Select Download Status
  8. In the behaviors.behaviorName.XX column for your language, filter for the behavior from the Check Tool
  9. Locate the externalCode column (column B) and copy the number (to be used in the next section)

II. Remove the Behavior from the Competency

  1. Navigate to Admin Center > Tools > Manage Talent Intelligence Hub
  2. Select the Attributes tab
  3. Locate the External Code search filter and enter the number from the externalCode column from Step 9 above > Go
  4. Click on the attribute
  5. Select Edit
  6. In the Behaviors section, select the behavior > Remove
  7. In the popup, select Remove
  8. Select Save

Keywords

migration, Check Tool, success factors, SF, SFSF, TIH, migrate, upgrade, behaviors, behavior, Cofc, Wsm, Post, Migration, Check, For, empty, Missing, In, CoC, During, Sync, Back , KBA , LOD-SF-TIH-MIG , Migration to Talent Intelligence Hub , LOD-SF-TIH-COC-ADM , Admin Center, Settings, Permissions , Problem

Product

SAP SuccessFactors HCM Suite all versions