Symptom
When running the checks for Talent Intelligence Hub application in Admin Center > Check Tool, issue for the check "WSMBehaviorMissingInCoCDuringSyncBackCheck" can be found.
Environment
- SAP SuccessFactors Talent Intelligence Hub
- SAP SuccessFactors Center of Capabilities
Cause
Behaviors are not synchronized back to Center of Capabilities
Resolution
I. Determine Which Competency the Behavior is Tied To
- Navigate to Admin Center > Tools > Import and Export data
- In the Select the action to perform dropdown, select Export
- In the Select Generic Object field, select Competency-Behaviors
- In the Include Inactive Records dropdown, select Yes
- Select Export > View Results
- Locate the job and select View Details
- Select Download Status
- In the behaviors.behaviorName.XX column for your language, filter for the behavior from the Check Tool
- Locate the externalCode column (column B) and copy the number (to be used in the next section)
II. Remove the Behavior from the Competency
- Navigate to Admin Center > Tools > Manage Talent Intelligence Hub
- Select the Attributes tab
- Locate the External Code search filter and enter the number from the externalCode column from Step 9 above > Go
- Click on the attribute
- Select Edit
- In the Behaviors section, select the behavior > Remove
- In the popup, select Remove
- Select Save
Keywords
migration, Check Tool, success factors, SF, SFSF, TIH, migrate, upgrade, behaviors, behavior, Cofc, Wsm, Post, Migration, Check, For, empty, Missing, In, CoC, During, Sync, Back , KBA , LOD-SF-TIH-MIG , Migration to Talent Intelligence Hub , LOD-SF-TIH-COC-ADM , Admin Center, Settings, Permissions , Problem