SAP Knowledge Base Article - Public

3470241 - It is Not Possible to Use the Contact's Language to Determine Preffered Language on Workflow Rule

Symptom

When sending an e-mail to a Contact that is assigned to an Account, you would like the Contact's Language preference to be used when determining the Language and respective template in the Workflow Rule.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the desired BO, for example, Service > Tickets;
  2. Open any Ticket;
  3. Perform an action that triggers your Workflow Rule to send e-mails;
  4. The Workflow sends out the e-mail in English (for example), which is the default template set in the rule. However, you expect it to send the e-mail in the Contact's language (for example, French) which is the recipient that will receive the e-mail.

Cause

A Contact can have more than one relationships with different Accounts. Contact can be Contact Person for Accounts A, B and C. In this scenario, the logic has to check if there is a relationship between the involved Account and the Contact, if there is a relationship, it needs to take the Account's Language.

The main reason why we cannot use the Contact's language is because it will never consider the Company's main Language and will always consider the Contact's language. This is not what the most businesses want.

Let's say I am the Contact Person for both SAP Canada and SAP Germany. SAP Canada has language 'EN' and SAP Germany has 'DE', and my personal language is set as "Korean" (my mother tongue). If I get an e-mail from a Workflow related to Ticket where the Account is 'SAP Canada', I expect to get this in language 'EN'. 

If I get an e-mail from a Workflow related to Ticket (for example) where the Account is SAP Germany, I expect to get this in language 'DE'. I don't expect all the e-mails are received in Korean just because my Contact level language is set as Korean. If I am the contact person for a company where the main language is 'EN', I expect to get e-mails in English.

Most Accounts (Companies) have one main language. If the company has two official languages like SAP Canada ('EN' and 'FR'), I will get e-mails with both languages in one e-mail. English version at the top and French Version at the bottom. If this is the case for your Accounts, we suggest you to create an e-mail template where it contains both languages.

Resolution

This is the expected system behavior.

We are constantly thriving to improve our system and hearing your suggestions is the best way forward. Our product managers regularly check the Influence page to hear what changes users would like to see in place and check those for feasibility. Idea requests can also be voted for by other customers.

If you would like to suggest a change to this behavior, please submit your idea at the respective SAP Influence page:

Please note that it is not possible for our Support Team to provide you additional information regarding the availability of this feature in a future release.

Keywords

WKF, email, sales quote, sales order, campaign, opportunity, lead , KBA , LOD-CRM-WKF , Workflow , LOD-CRM-OPP , Opportunity Management , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer core applications all versions