Symptom
You have configured an Access Restriction for Service Tickets based on "Employee" and also created a Party Role in Business Configuration with the Party Category as "Sales Employee Party".
When you add the Custom Party Role in Ticket and add an Employee to it, this Employee cannot see the Ticket.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Login as affected employee
- Try to find the Tickets where this Employee is added as the Sales Employee Party
- You do not see the Ticket
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- Log on as admin
- Open the respective Ticket
- You will see that affected employee is assigned to the ticket with two "Sales Employee Roles"
Cause
When creating custom Party Roles, the "Sales Employee Party" Party Category is meant to be used only with Sales Documents, not with Service documents such as Tickets. Hence it will not be relevant for Ticket access restriction settings.
Resolution
Create another Custom Party Role with Party Category "Other Party", and then this role will be relevant for access restriction in Tickets
Keywords
Sales Employee Party, Access Restriction, Ticket, Employee, Party Role , KBA , LOD-CRM-SRP-PAP , Ticket - Party Processing , How To