SAP Knowledge Base Article - Public

3470518 - Duplicate messages triggered for Business Partners via the SOAP API in S4 HANA Cloud

Symptom

  • Duplicate outbound messages are triggered via SOAP API
  • Application Message ID numbers are identical but with different message ID numbers
  • Duplicate messages queue on the target system with one cancelled

Environment

SAP S/4HANA Cloud 

Reproducing the Issue

  1. Go to Manage Business Partner Data APP and select an existing Business Partner
  2. Update Business Partner data and save
  3. Two outbound messages are triggered from the S4 system
  4. Messages can be viewed in the Message monitoring APP

Cause

  • SAP_COM_0008 Communication Arrangement is active for replication from a C4C source system to S4 HANA Cloud 
  • SAP_COM_0025 Communication Arrangement is active for replication from a C4C source system to S4 HANA Cloud 

Resolution

Review the configuration of the Communication Arrangements SAP_COM_0008 & SAP_COM_0025 requirement

To stop the duplicate message disable one of the Communication Arrangements depending on business requirement

See Also

Create Communication Arrangement for Business Partner Object

Keywords

duplicate, messages, soap, Id, SAP_COM_0008, SAP_COM_0025  ,c4c, integration, application , KBA , LO-MD-BP-WS , Web Service for Business Partner , How To

Product

SAP S/4HANA Cloud Public Edition 2402