SAP Knowledge Base Article - Public

3470527 - Workflow Rule for Recipient Determination: "Manager of Agent Responsible for Ticket" is Not Triggered

Symptom

You create a workflow rule for Recipient Determination: "Manager of Agent Responsible for Ticket". All the conditions are met but the workflow rule is not triggered.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Administrator work center
  2. Go to the Workflow Rules view
  3. Click New to create a new workflow rule *Rule Type must be the one which has Recipient Determination, and select "Manager of Agent Responsible for Ticket"
  4. Click Active
  5. Click Finish
  6. Go to the Service work center
  7. Go to the Ticket view
  8. Open a ticket *Ticket must fulfil the conditions of the workflow rule created at step 5
  9. Edit the ticket
  10. Click Save

Result: The workflow rule is not triggered even though the conditions are met.

Expected Result: The workflow rule is triggered as the ticket fulfil the conditions.

Cause

A manager is not maintained for the Agent Responsible for the Ticket (Assigned To). Therefore, there is no recipient to receive the e-mail, and the workflow rule is not triggered.

Note

  • If a Timing of the workflow rule is On Every Save => The system checks the conditions of the workflow and the recipient of the e-mail. If there is no recipient, the workflow rule is not triggered.
  • If a Timing of the workflow rule is Scheduled => The system checks the conditions only and schedules the workflow rule. When the workflow rule is executed, the system checks the recipient and the workflow rule is not triggered if there is no recipient.

Resolution

This is an expected system behavior.

Keywords

workflow, rule, Manager of Agent Responsible for Ticket, assigned to, ticket, trigger , KBA , LOD-CRM-WKF , Workflow , How To

Product

SAP Cloud for Customer core applications 2402