Symptom
When a Task is added to a Visit via Routing Rules, deleting the Visit also results in the deletion of the Task.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Open any Visit
- On the Tasks tab, add a Task from a Routing Rule
- Delete the Visit
- Go to Activities > Tasks
- The Task is now also deleted
Cause
When a Task is added to a Visit via Routing Rules, a new Task is created for each individual Visit. Once the Visit is deleted, the Task is no longer needed as it is unique to that Visit, so it is deleted as well.
Resolution
This is the expected system behaviour
Keywords
delete task, delete visit, visit, task , KBA , LOD-CRM-ACT-VST , Visit Planning , Problem
Product
SAP Cloud for Customer core applications 2405