Symptom
The file generated by the system is not correct and it was refused by the bank. The issue is in the Company's name, when the system uses a code instead of the Company's name.
This behavior can be found in the XML file via tag: <Nm><Nm>.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Liquidity Management work center.
- Go to Outbound Files subview.
- Select "All Outbound Files".
- Search for File ID: XYZ (XYZ represents the file ID) and open it.
- Go to Attachment tab and download the file.
- Open the file and go to the bottom of the file there is the following tag: <Nm>DEF</Nm> (DEF represents the Customer ID at Bank). As per bank requirements, this is wrong and should be the company name.
Cause
The file is getting the Creditor Name filled with the Customer ID at Bank Code instead of the company name because the Customer ID at the Bank represents the Account Holder Name at the bank.
The Account Holder name has priority over the company name for payments, and this is why it is being passed on in the file.
Resolution
To avoid this issue, we can enhance the company details in the Customer or Supplier master data of the Business Partner, and add the company bank data in the company's financial data (the company can also be a maintained with the role of supplier). To add the company bank data, please follow the steps below:
- Go to Business Partner work center
- Go to Accounts.
- Search for Account ID: ABC (ABC represents the Account ID).
- Click "Edit" button > Financial Data > Go to Bank Data subtab.
When Maintaining the Customer or Supplier bank details, we should remember to keep the "Account Holder" field empty, unless the account holder varies from the company name.
This way, the payments can be made without any issues.
Keywords
Company name incorrect, Tag, <Nm>, XML file, Outbound File, Customer ID at Bank. , KBA , AP-PAY-GLO , Cross-Country Extensions , How To