SAP Knowledge Base Article - Public

3470994 - ODATA API Error : [COE0018] Workflow status is : SENTBACK. Action denied.

Symptom

You are trying to perform an ODATA API UPSERT operation to update the Workflow Approver but you get below error:

[COE0018]???Workflow status is : SENTBACK. Action denied.??


DISCLAIMER:
 Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
 

Environment

  • SAP SuccessFactors HCM Suite
    • Integrations
      • ODATA

Cause

This is an expected behaviour.

Resolution

When the workflow is in the SENTBACK state, the approver cannot be changed via ODATA API nor from UI.

For the SENTBACK workflow, you can either use Initiator to re-Submit the request. If the Initiator is not valid, then you can do 'Change Initiator' via Manage Workflow Requests and then use New Initiator to re-submit the workflow.

Please refer KBA-2080722 - How to manage & modify a Workflow that is in progress - Employee Central

Keywords

[COE0018] Workflow status is : SENTBACK. Action denied, [COE0018]???Workflow status is : SENTBACK. Action denied.??, LOD-SF-INT, LOD-SF-INT-ODATA, Workflow Approver Change, Workflow Upsert , KBA , LOD-SF-INT-API , API & Adhoc API Framework , LOD-SF-INT , Integrations , LOD-SF-INT-ODATA , OData API Framework , Problem

Product

SAP SuccessFactors HCM Core 2405 ; SAP SuccessFactors HCM Suite 2405