Symptom
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
When access Ask HR application from SuccessFactors home page, the following error is encountered.
ERROR: HTTP Status 500 - An internal application error occurred. Request: 2533505125 gabekoxvyx:flpnwc
Environment
SAP SuccessFactors HXM Suite
* Ask HR / EC Service Center
Cause
The error is produced while calling the following Request URL by Ask HR application.
This means either the javaproxy does not exist in SAP BTP Cockpit -->Connectivity --> Destinations or it is not configured correctly.
Resolution
When you enable Employee Central Service Center Preview or Production in SAP BTP Cockpit --> Services, javaproxy is configured automatically.
If it is not created automatically then you will have to create it manually under SAP BTP Cockpit -->Connectivity --> Destinations as shown in the below screenshot.
See Also
Refer the EC Service Center implementation guide for details.
Keywords
javaproxy, destinations, BTP cockpit, SAP SuccessFactors EC Service Center (Preview), SAP SuccessFactors EC Service Center (Production), destination, Ask HR , KBA , LOD-SF-INT-AHR , Ask HR - Employee Central Service Center (ECSC) , Problem