Symptom
You are trying to reject a Time Entry in the Employee Times tab, however the system is showing the following error message:
Posting results in insufficient quota for account Vacation.
Environment
SAP Business ByDesign.
Reproducing the Issue
- Go to Time Administration work center.
- Then go to the Employees view.
- Search for the affected Employee.
- Then click Edit button.
- Go to Employee Times tab.
- Search for a required Time/Date, which is under 'In Approval' status.
- Click Actions > Reject.
- Error occurs.
Cause
We have identified that overbookings in the Vacation time account are causing this issue.
Once you try to reject a time recording, the system checks for consistency in the whole Time Profile, not only on the specific time recording/time account being affected.
Resolution
In order to fix this error, you would need to perform manual adjustments for the affected Vacation (Time Account) to resolve the inconsistency.
Please follow the steps below to perform manual adjustments:
- Go to Time Administration Work Center.
- Then go to the Employee view.
- Search for the affected Employee.
- Click Edit button.
- Go to Time Account Balances tab.
- Select Vacation (Time Account) and go to Adjustments tab.
- For the affected date posting do the changes to quantity from the negative value (e.g -3) to 0.
- Save the changes.
After the steps above, please try to reject the Time Entry once again.
See Also
Keywords
Posting results in insufficient quota for account Vacation, Time Administration, Employee, Employee Times, Error, Cannot, Unable, Reject, Approve, Actions. , KBA , SRD-HR-TLM , Time and Labour Management , How To