Symptom
You are unable to select the SFAPI option in API Center - Audit Log Settings as below
Disclaimer: Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HCM Suite
- Integrations
- SFAPI
- Integrations
Cause
This is because the Login User has missing RBP Permission.
Resolution
Please check if the below mentioned RBP permission is provided to the Login User or not.
- Login to Successfactors and search for "Manage Permission Roles" and search for the Permission Role
- Now Click on Edit and then go to Add Permissions to search for " Manage Integration Tools"
- Then select the permission "Access to SFAPI Audit Log" and then click on Save.
Once the RBP permission is saved you will have to Logout and Login again to refresh the Permission and the SFAPI Audit will be enabled to select.
See Also
Keywords
SFAPI, Audit Log Settings, SFAPI Disabled, API Disabled, LOD-SF-INT-API, SFAPI greyed out , KBA , LOD-SF-INT-API , API & Adhoc API Framework , LOD-SF-INT , Integrations , LOD-SF-INT-CE , Compound Employee API , Problem
Product
Attachments
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