Symptom
When we are completing New Hire Data Review/Personal Data Collection or Manage Pending Hires, we are unable to submit the information due to the following error: "No event or event reason found for the user 1234"
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Navigate to ONB Dashboard
- Access the candidate in ONB Dashboard
- Maintain the Event Reason
- Complete the next sections and submit the review new hire data step Error pops up on submission
NOTE: The error is usually reproducible when the hire date has been changed.
Cause
- With the recent enablement of Service Layer, it is mandatory to pass the event reason during the onboarding initiation.
- If the Event Reason is not passed and the start date is changed during the onboarding process, the EC Table (EMP_JOB_INFO_T) is not updated with a valid Event/Event Reason Id.
- Since the table does not have a valid event, system will throw an error
NOTE: This is a behaviour change since 1H 2024 due to the introduction of Centralized Services for Onboarding Pages. You may read more about it in the "Also See" section.
Resolution
To resolve the error for Existing Candidates:
Solution 1:
- Do not change the start date during the onboarding process.
- Complete the onboarding process with the existing start date and complete Manage Pending Hire step for the candidate.
- Once Manage Pending Hire is completed, use the Hire Date Correction Tool to change the start date.
Solution 2:
- Complete the New Hire Data Review step with the existing start date.
- Once New Hire Data Review us submitted, change the start date using Access New Hire Data Page.
Follow the below steps to change the start date using new hire data page:
- Go to the Onboarding Dashboard
- Find the candidate (After New Hire Data Review is completed and event reason is maintained)
- Click on Actions > New Hire Data
- Update the start date and verify if the event reason is already available
- Submit New Hire Data Review
To avoid seeing such validation messages in the future:
It is necessary to ensure that the Event Reason is passed when onboarding is initiated. You can pass the event reason using any one of the below methods:
Option 1: Pass the event reason from RCM via Picklist
- Reference KBA: How to Map Event Reason from RCM to Onboarding
NOTE: This is just one sample method. You can reach out to your RCM Consultant if you would default the event reason via business rule from Recruiting or pass it as a string field.
Option 2: Pass the event reason via Derivation Business Rule in EC.
- Reference Guide Link: Configuring Business Rule for Event Reason
See Also
Keywords