SAP Knowledge Base Article - Public

3472782 - Login to Microsoft Teams Tab Does Not Work for SAP Sales and Service Cloud V2

Symptom

Cannot log in to a Microsoft Teams tab, e.g. Deal room tab. After click on Sign in button, it returns to Sign in page.

Environment

  • SAP Service Cloud v2
  • SAP Sales Cloud v2

Reproducing the Issue

  1. Open Teams Application.
  2. Navigate to Teams.
  3. Open an MS Teams tab, e.g. Deal room.
  4. Click on Sign In button.
  5. It loads for some time, and it returns to Sign in page.

Cause

In Cross-Site Request Forgery Settings, the Strict mode is enabled by default for third-party integrations.

Resolution

You must change Cross-Site Request Forgery Settings to None for the MS Teams Integration to work fine. Please follow below steps to fix the issue:

  1. Log in to the system as an administrator.
  2. Navigate to user profile on the right-top corner, and access the Settings page.
  3. Go to All Settings.
  4. Under Users and Control section, go to Settings.
  5. Set the mode to None.
  6. Save.

See Also

Microsoft Teams Integration

Keywords

Microsoft Teams, Cross-Site, Forgery, Sign in, SSO, Log in, MS Teams , KBA , CEC-CRM-TMS , Microsoft Teams Integration , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0