Symptom
Cannot log in to a Microsoft Teams tab, e.g. Deal room tab. After click on Sign in button, it returns to Sign in page.
Environment
- SAP Service Cloud v2
- SAP Sales Cloud v2
Reproducing the Issue
- Open Teams Application.
- Navigate to Teams.
- Open an MS Teams tab, e.g. Deal room.
- Click on Sign In button.
- It loads for some time, and it returns to Sign in page.
Cause
In Cross-Site Request Forgery Settings, the Strict mode is enabled by default for third-party integrations.
Resolution
You must change Cross-Site Request Forgery Settings to None for the MS Teams Integration to work fine. Please follow below steps to fix the issue:
- Log in to the system as an administrator.
- Navigate to user profile on the right-top corner, and access the Settings page.
- Go to All Settings.
- Under Users and Control section, go to Settings.
- Set the mode to None.
- Save.
See Also
Keywords
Microsoft Teams, Cross-Site, Forgery, Sign in, SSO, Log in, MS Teams , KBA , CEC-CRM-TMS , Microsoft Teams Integration , Problem
Product
SAP Sales Cloud and SAP Service Cloud Version 2 1.0