Symptom
Preview of output document does not work for custom template. It throws error "No variant found for language xx" in developer tools.
Environment
- SAP Service Cloud v2
- SAP Sales Cloud v2
Reproducing the Issue
- Go to affected entity, e.g. Cases.
- Open any.
- Click on the 3 dots on left side.
- Select Summary.
- Result: Nothing happens.
- If you open developer tools, you will see the error "No variant found for language xx" in Network trace.
Cause
A. You do not have a variant with the affected language.
B. You have a variant with language and country fields populated. And the request made to output management is to return a template with just language "xx".
Resolution
A.
- Click on the User Menu button.
- Navigate to Settings → All Settings.
- Open Maintain Form Template under Output Management section.
- Expand Affected Template.
- Expand the custom template.
- Click on the Add form Template variant button.
- Make sure in the language field you set the language from the error message.
- Click on Save & Publish button.
B.
- Click on the User Menu button.
- Navigate to Settings → All Settings.
- Open Maintain Form Template under Output Management section.
- Expand Affected Template.
- Expand the custom template.
- Click on the 3 dots button for the variant
- Select Copy Variant
- Erase the value for Country field and leave it empty
- Click on Save & Publish button
See Also
Keywords
Template, Form, Output, Summary, Variant, Language , KBA , CEC-CRM-OUT , Output Management for SAP Sales/Service Cloud , How To
Product
SAP Sales Cloud and SAP Service Cloud Version 2 1.0