SAP Knowledge Base Article - Public

3472948 - Custom Form Template Output Preview Does Not Work

Symptom

Preview of output document does not work for custom template. It throws error "No variant found for language xx" in developer tools.

Environment

  • SAP Service Cloud v2
  • SAP Sales Cloud v2

Reproducing the Issue

  1. Go to affected entity, e.g. Cases.
  2. Open any.
  3. Click on the 3 dots on left side.
  4. Select Summary.
  5. Result: Nothing happens.
  6. If you open developer tools, you will see the error "No variant found for language xx" in Network trace.

Cause

A. You do not have a variant with the affected language.

B. You have a variant with language and country fields populated. And the request made to output management is to return a template with just language "xx".

Resolution

A.

  1. Click on the User Menu button.
  2. Navigate to Settings → All Settings.
  3. Open Maintain Form Template under Output Management section.
  4. Expand Affected Template.
  5. Expand the custom template.
  6. Click on the Add form Template variant button.
  7. Make sure in the language field you set the language from the error message.
  8. Click on Save & Publish button.

B.

  1. Click on the User Menu button.
  2. Navigate to Settings → All Settings.
  3. Open Maintain Form Template under Output Management section.
  4. Expand Affected Template.
  5. Expand the custom template.
  6. Click on the 3 dots button for the variant
  7. Select Copy Variant
  8. Erase the value for Country field and leave it empty
  9. Click on Save & Publish button

See Also

Form Templates

Keywords

Template, Form, Output, Summary, Variant, Language , KBA , CEC-CRM-OUT , Output Management for SAP Sales/Service Cloud , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0