SAP Knowledge Base Article - Preview

3473528 - Failed dependencies during upgrade to SAP Cloud Connector 2.17

Symptom

  • An upgrade to SAP Cloud Connector 2.17 fails with error:

    Failed dependencies:
            libstdc++.so.6(GLIBCXX_3.4.20)(64bit) is needed by com.sap.scc-ui-2.17.0-21.x86_64
            libstdc++.so.6(GLIBCXX_3.4.21)(64bit) is needed by com.sap.scc-ui-2.17.0-21.x86_64 

  • The portable version of SCC 2.17 fails with:

    [main] INFO com.sap.scc.jni - Load native library libsapscc20jni.so from /usr/sap/scc/./lib/native

    Exception in thread "main" java.lang.UnsatisfiedLinkError: /usr/sap/scc/lib/native/libsapscc20jni.so: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /usr/sap/scc/lib/native/libsapscc20jni.so)


Read more...

Environment

SAP Cloud Connector 2.17.0
Red Hat Enterprise Linux 7

Product

connectivity proxy for SAP Connectivity service all versions

Keywords

RedHat, SCC, release, kernel, glibc , KBA , BC-MID-SCC , SAP Cloud Connector On-Demand/On-Premise Connectivity , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.