SAP Knowledge Base Article - Public

3475294 - Certificate errors when connecting to REST/SOAP endpoints - Integration Center

Symptom

An error was found in the Integration Center logs:

  • "Unable to find valid certification path to requested target"
  • OR "Available Certificates could not establish trust; upload certificate using Security Center >> Https Trust Certificate Management"

Environment

SAP SuccessFactors HCM Suite

Reproducing the Issue

  1. Go to Integration Center
  2. Create an integration with destination as REST/SOAP URL
  3. Run the integration

Cause

Trust certificates in the common trust store and the trust certificates in the tenant trust store doesn't have a right certificate to trust the service.

Resolution

  1. Go to Admin Center > Security Center > HTTPS Trust Certificates;
  2. Click on Add and fill the API URL used in the integration;
  3. Verify the server URL;
  4. Pull and upload the trust certificate;

OBS.: You should keep this trust certificate updated when renewing the destination system certificate.

See Also

Integration Center guide

Keywords

Integration Center, Security Center, HTTPS Trust Certificates, unable to find valid certification path to requested target , KBA , LOD-SF-INT-INC , Integration Center , Problem

Product

SAP SuccessFactors HCM Suite all versions