Symptom
- A custom field was not added to the 'Change Field Catalog for Pricing in Sales' in SAP S/4HANA Cloud.
- For example, an error message was displayed: 'Field YY1_CUSTOMFIELD_SDI does not exist in table KOMG, KOMK, or KOMP'.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
1. Navigate to 'Change Field Catalog for Pricing in Sales' in SAP S/4HANA Cloud.
2. Attempt to add the custom field 'YY1_CUSTOMFIELD_SDI'.
Cause
The custom field was not enabled for UI, API and SOAP API scenarios in the Custom Field app.
Resolution
1. Navigate to the Custom Field app in SAP S/4HANA Cloud.
2. Enable the custom field 'YY1_CUSTOMFIELD_SDI' for UI, API, and SOAP API scenarios.
3. Retest the system behavior.
Keywords
Custom Field, Pricing in Sales, KOMG, KOMK, KOMP, Field Catalog , KBA , SD-MD-CM-2CL , Conditions and Condition Maintainance (Public Cloud) , Problem