SAP Knowledge Base Article - Public

3475631 - Case Authorization based on Service Org. Unit not working

Symptom

You have configured Case Write Access based on the Service Organization of a user. However, when trying to edit a case that has a Service and Support Team with the same Parent Unit as the Service and Support Team the current user is assigned to,. The following error occurs: You are not authorized to change the data. 

Environment

SAP Service Cloud Version 2

Reproducing the Issue

  1. Login as a Support User
  2. Go to Cases
  3. Open a Case which has a Service and Support Team assigned, which shares a Parent Unit with the Service and Support Team your user is assigned to.
  4. When attempting to edit the Case, the following error occurs: You are not authorized to change the data.

Cause

The Service Organization Party Role was not added to the Party Schema used in the Case Type of the Case you are facing the error.

Resolution

  1. Go to Settings
  2. Go to Case Settings
  3. Select Party Schema
  4. Select Case Party Schema
  5. Select Edit Pencil
  6. Make Service Organization Active
  7. In the Actions Section also mark it Active
  8. Delete Service and Support Team from Part Schema and then add it back, determination will then be taken from Service Organization.

Following this

  1. Go to the Case Type Settings
  2. Select the Three Dots on the Case Type Used
  3. Create a new version of the Active Case Type
  4. Add in the New Party Schema along with other details

Keywords

Case, Access Restrictions, Org Unit , KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0