SAP Knowledge Base Article - Public

3475822 - Process for Adding a Standard Note Type to Case via API

Symptom

You wish to add a Standard Note Type S001 to a Case via API. S001 is a description Note which means a description reference must be given.

Environment

SAP Service Cloud Version 2

Cause

Note Type S001 is a Standard Description Note Type, as a result it needs to be given a reference to a Case.

The description reference should only be used for Notes of Type description.

Resolution

In order to Create the Note you can use the following request and body.

https:/<TenantUrl>/sap/c4c/api/v1/note-service/notes

{
    "noteTypeCode": "S001",
    "htmlContent": "<p>"Description"</p>"
   
   
}

In order to reference the Note Type to a Case you can use the following request and body.

Patch: https://<TenantUrl/sap/c4c/api/v1/case-service/cases/<CaseID>

{
    "description": 
        {
            "noteId": "<Populated with Note ID taken from the Response from the above Post request that created the note>"
        }
    
}

Once the above steps are done the Note will appear in the description section of the Case on the UI.

Keywords

Api, Note, Case , KBA , CEC-CRM-NOT , Notes for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0