SAP Knowledge Base Article - Public

3476107 - Workflow for Contact Business Object is Not Triggered When Updating Phone, Mobile or E-mail Field

Symptom

You create a workflow rule for the Contact Business Object. (e.g. On Every Save) When you update a Phone, Mobile or E-mail field, the workflow is not triggered even the conditions are met.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Administrator work center
  2. Go to the Workflow Rules view
  3. Create a Workflow Rule for the Contact Business Object (e.g. Rule Type = Field Update, Timing = On Every Save, Condition Status Equal To Active)
  4. Go to the Customers work center
  5. Go to the Contacts view
  6. Open the Contact 123 whose status is Active (Where 123 refers to the Contact ID)
  7. Click Edit
  8. Update the Phone, Mobile or E-mail field

Result: The Workflow is not triggered although the condition(s) is met.

Cause

Not all the fields (including standard fields) send a notification to trigger the Workflow Rules when changes happen. The Phone, Mobile and E-mail are this type of field so that the Workflow Rules are not triggered, and this this is an expected system behavior. 

Resolution

An option may be to check the SAP Cloud for Customer Customer Influence to submit an idea:

Keywords

workflow, rule, contact, trigger, not, phone, mobile, e-mail, email, field, update , KBA , LOD-CRM-WKF , Workflow , Problem

Product

SAP Cloud for Customer core applications 2405