SAP Knowledge Base Article - Public

3476171 - How to Delete Individual Customers from the System

Symptom

Inability to delete individual customers from the system

Environment

SAP Cloud for Customer

Reproducing the Issue

1. Access the Customers work center.
2. Navigate to the Individual Customers work center view.
3. Verify that there is no available option to delete individual customers.

Cause

  • Individual customers are considered as master data in the system and are not meant to be deleted.
  • The system does not provide an option to delete individual customers in order to maintain data integrity and historical records.
  • Deleting individual customers can lead to data inconsistencies and affect other related processes or transactions.
  • Instead of deleting individual customers, the recommended approach is to block or obsolete them, which allows for maintaining the data while preventing further use or updates.

Resolution

  1. Log in to your C4C system
  2. Navigate to the Customers work center
  3. Navigate to the Individual Customers 
  4. Search for and select the customer you want to block or obsolete
  5. Open the customer's details by clicking on their name
  6.  Click on the Actions button.
  7.  Look for the Block/Obsolete and select the appropriate option (Block or Obsolete) from the dropdown menu
  8.  Save your changes by clicking on the Save button

Keywords

Block, Obsolete, Individual Customers, master Data , KBA , LOD-CRM-ACC-PRI , Private Account (Customers) , Problem

Product

SAP Cloud for Customer core applications 2405